Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2020-03-10 Sync
#1
Sync
I just walked into a building and teleported into the ocean miles away. Pick your variation of this event. It happens to everybody at some point.

Another symptom was a lag spike that always hit me when launching from Atlantis, just as the fighter left the ship. That is where I would sometimes find myself at the bottom of the sea.

Redesigned the way certain syncronizations are negotiated between the client and server. This eliminates the jitter and fixes a number of reported issues.

A lot of crucial things are affected, like respawning, teleporting, transporters, getting in/out of vehicles, wormholes, warp travel, turbo lifts, entering leaving spacecraft, entering leaving the domain of worlds. I tested all of those things, more thoroughly than usual, but there is always potential for a problem. Please be patient if there is a problem.

Hit Sync Lag
When character or any driveable vehicle that is under control by player gets hit by weapon or fists or anything like that, it stuck on one place for a second. Unable to move and rotate camera. This gets worse when there are many sources of damage

This was fixed by the previous work on sync.

Previously, it was not possible to induce a vector onto a player controlled avatar; it didn't propagate to the avatar properly, ending up as a lag spike instead. Now you will be moved by explosions and kinetic damage to your body. Large animals may throw your body quite far when hitting you.

Try having a fist fight with an indigenous person. I think it feels more solid when your blows knock them back a bit.

Cache Options
Cache options still mention old style ship designs.

Removed references to old style spacecraft designs.

Bullion Q
Bullion production says "Produced x at Q141"

Bullion production is always Q255. The manufacturing panel was showing incorrect information. The information is fixed.

Gov Policy
Government Office > Can change join policy and password

Removed obsolete join policy permission

Republish Design
Should be able to republish a design with the same name. It can tell you that's what happened.

Fixed error that prevented republishing an existing design. The error reported a duplicate name which should have been ignored when overwriting a design id. The new design replaces the old design with the same name. Duplicate entries are not created.

Gas Giant Refineries
Refineries in gas giants dont "see" exotic atmospheres

Fixed.

Sky Box Seams
Since the update on the 21st, I see large seams in the skybox

I could not find any error or cause for the seams at the edges of each panel.

There is a setting to disable mip mapping of the skybox texture. You could try that.

I added a debug switch to disable GL_TEXTURE_CUBE_MAP_SEAMLESS when drawing the sky box. You can try that. It's a rendering state that affects the seam. It is the b31 switch on the Program page of the Settings window. The check box has a tooltip. If that works for you, I'll replace the debug switch with a setting on the Scene page.

Empire Standings
Empire standings pages have links that say 2015.

Year reference removed fromĀ empire standings pages.

Big Flags
Flags larger than 64x64 are causing sizing problems on the web site.

Big flag size issues fixed on web pages.

Blank Paper in Notebook
I made a notebook with a bunch of blank pieces of paper. I put my welcome letter in there and I can't tell which one it is in the list.

Blank paper is now identified as "Blank Paper" in the gear list.

Bought Blueprint Error
I bought a blueprint onto one of the blank pages of my notebook. I got the blueprint but it didn't use up the blank page.

Fixed an error finding the media when it was inside a nested container. My notebook was in my backpack. The user interface found the blank pages and listed them for storing the blueprint. The server did not find the blank paper inside the nested container so it was not removed.

System Map Error
When I display my solar system map, the first planet starts with roman numeral II.

Fixed an error that was introduced in a recent update.
Reply
#2
(03-10-2020, 06:37 PM)Haxus Wrote: Sync
... Please be patient if there is a problem.

Can't enter in-game design studio. I am instead teleported to the north pole of my world.
Shores of Hazeron Wiki Moderator
hazeron.com/wiki/ User: Deantwo
Reply
#3
(03-10-2020, 07:46 PM)Deantwo Wrote:
(03-10-2020, 06:37 PM)Haxus Wrote: Sync
... Please be patient if there is a problem.

Can't enter in-game design studio. I am instead teleported to the north pole of my world.

Didn't know Santa was getting into the Spacecraft building business Wink
Reply
#4
I forgot to mention this one.

Planetoid Zone
The best source of lumenite in my system is on a planetoid. It sounded like a fun challenge, to build a lumenite mine on a planetoid.

Attempting to land on the planetoid with a rocket was entertaining at first, then became very frustrating. I think it may be impossible.

The zone of control of planetoids is larger now. This makes the transition much easier, outright easy.

However, my sync changes may have broken something else. In my attempt just now to land on that planetoid with a rocket, my rocket's speed dropped to zero when I entered the zone of the planetoid. This is the sort of problem that I thought might be seen as a result of the sync changes. It is just a nuisance, not a major problem.
Reply
#5
(03-10-2020, 09:19 PM)Haxus Wrote: Attempting to land on the planetoid with a rocket was entertaining at first, then became very frustrating. I think it may be impossible.

Challenged accepted. But not now I am busy doing other thing.
Reply
#6
(03-10-2020, 09:46 PM)Norm49 Wrote:
(03-10-2020, 09:19 PM)Haxus Wrote: Attempting to land on the planetoid with a rocket was entertaining at first, then became very frustrating. I think it may be impossible.

Challenged accepted. But not now I am busy doing other thing.

That text was grayed out. Meaning that that is the bug report notes, so it should be fixed now as he mentioned below that.
Shores of Hazeron Wiki Moderator
hazeron.com/wiki/ User: Deantwo
Reply
#7
Recall Home seems to be broken right now.
First attempt to recall to a ship teleported me inside the local star, which killed me instantly and forced me into an infite death loop as I also respawned inside the star (the ship itself stayed safely in orbit above the place I was recalling from). After a restart of the game I spawned on the ship.
Now I've switched berths, and trying to recall to a different ship in the same system just makes my character drop to the ground after a few "pulses" of the recall graphical effect. No loading screen, no movement, nothing. Avatar just drops down like I hit the prone button.
Deltova - Havenite Shipyards
Reply
#8
(03-10-2020, 10:41 PM)DFDelta Wrote: Recall Home seems to be broken right now.
First attempt to recall to a ship teleported me inside the local star, which killed me instantly and forced me into an infite death loop as I also respawned inside the star (the ship itself stayed safely in orbit above the place I was recalling from). After a restart of the game I spawned on the ship.
Now I've switched berths, and trying to recall to a different ship in the same system just makes my character drop to the ground after a few "pulses" of the recall graphical effect. No loading screen, no movement, nothing. Avatar just drops down like I hit the prone button.

I get something similar when attempting to teleport to an alt avatar on the surface below my avatar's ship.
I accept the teleport offer and I get a short loading screen, I am still on my ship in orbit, but all the crew is gone. I swap to another avatar and then back, now my avatar is on the opposite side of the planet. I accept the teleport offer again, again after loading it doesn't look like i moved. I then swap back and forth between avatars again and now my avatar is finally at the destination i was offered the teleport to.
Shores of Hazeron Wiki Moderator
hazeron.com/wiki/ User: Deantwo
Reply
#9
Sorry about the teleporting bugs. I'm working them out one by one. I'll post an update as soon as possible.

It's never quite the same on the real servers as the debug servers.
Reply
#10
Good to see some attention to sync, I've noticed a few oddities over the last few months, and figured it was a connection issue, or something like that. speed dropping to 0 when approaching ringworlds, bouncing off ships instead of colliding and exploding together, teleporting a ship randomly across a system while chasing a planet, etc.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)