2017-07-21 Surface Effects

Details about updates to Shores of Hazeron

Re: 2017-07-21 Surface Effects

Postby AnrDaemon » Fri Jul 28, 2017 1:36 pm

If your servers have IP KVM, anything can be fixed remotely.
But alas. If not, then not.
Yak. Yak never changes.
AnrDaemon
 
Posts: 7369
Joined: Wed Jun 15, 2011 5:37 pm

Re: 2017-07-21 Surface Effects

Postby Haxus » Sat Jul 29, 2017 12:04 pm

The servers do appear to have IP KVM. I didn't know about it until I got busy working on them. It could have been useful. I have never used it so it could have been a learning experience.

I have done some investigating into the crash when loading a .SoH file. I cannot reproduce the crash and I can load every .SoH file I have, some of which were sent by players.

I am seeing a Qt window error, new since installing the new video board. It could be related. I am working to find the exact cause of that error, though it doesn't appear to have any negative side-effect (on my computer), other than the error message. It is difficult to trace because it is coming from a module that gets loaded at runtime, not a regular library.

I am also building an update from clean source, in case there was some kind of error there. I don't like doing that because it's just a random shot in the dark, like rebooting a computer to fix a problem. Sometimes it works though.
User avatar
Haxus
Site Admin
 
Posts: 2619
Joined: Fri Jan 14, 2011 8:00 pm

Re: 2017-07-21 Surface Effects

Postby Celarious » Sat Jul 29, 2017 12:13 pm

Haxus wrote:The servers do appear to have IP KVM. I didn't know about it until I got busy working on them. It could have been useful. I have never used it so it could have been a learning experience.

I have done some investigating into the crash when loading a .SoH file. I cannot reproduce the crash and I can load every .SoH file I have, some of which were sent by players.

I am seeing a Qt window error, new since installing the new video board. It could be related. I am working to find the exact cause of that error, though it doesn't appear to have any negative side-effect (on my computer), other than the error message. It is difficult to trace because it is coming from a module that gets loaded at runtime, not a regular library.

I am also building an update from clean source, in case there was some kind of error there. I don't like doing that because it's just a random shot in the dark, like rebooting a computer to fix a problem. Sometimes it works though.


I'd be willing to send you a debug log, but I'm not sure whether they'd contain crash info
Image
User avatar
Celarious
 
Posts: 384
Joined: Sat Apr 09, 2011 1:20 pm
Location: EVA

Re: 2017-07-21 Surface Effects

Postby Onepercent » Sat Jul 29, 2017 12:19 pm

I suspect it's from the surface effects update, Jack Katogh from here> viewtopic.php?f=6&t=9176
has managed to load the designs that were crashing before successfully by just not enabling the designs face mode, in other words, turn off the inside and outside show faces option and just leave in wireframe mode.
User avatar
Onepercent
 
Posts: 136
Joined: Thu Mar 10, 2016 3:23 am

Previous

Return to Updates

Who is online

Users browsing this forum: No registered users and 1 guest