2016-08-03 Linux Package Requirements

Details about updates to Shores of Hazeron

Re: 2016-08-03 Linux Package Requirements

Postby asphere8 » Mon Oct 10, 2016 2:02 am

Any info on what I need to get Hazeron going on Arch Linux?
User avatar
asphere8
 
Posts: 99
Joined: Wed Jan 09, 2013 8:43 pm

Re: 2016-08-03 Linux Package Requirements

Postby AnrDaemon » Mon Oct 10, 2016 10:20 am

ldd "./Shores of Hazeron"
?
Yak. Yak never changes.
AnrDaemon
 
Posts: 7470
Joined: Wed Jun 15, 2011 5:37 pm

Re: 2016-08-03 Linux Package Requirements

Postby zephar » Fri Oct 14, 2016 6:29 pm

asphere8 wrote:Any info on what I need to get Hazeron going on Arch Linux?


Try running it in terminal it should tell you what packages you are missing. I have never tried SOH in Arch Linux.
zephar
 
Posts: 320
Joined: Sun Jan 16, 2011 11:39 am

Re: 2016-08-03 Linux Package Requirements

Postby asphere8 » Sun Oct 16, 2016 10:18 pm

zephar wrote:Try running it in terminal it should tell you what packages you are missing. I have never tried SOH in Arch Linux.
Done before I posted. I ended up with a few errors I couldn't track down; different errors with each version of Hazeron.
User avatar
asphere8
 
Posts: 99
Joined: Wed Jan 09, 2013 8:43 pm

Re: 2016-08-03 Linux Package Requirements

Postby Jey123456 » Sun Oct 16, 2016 10:57 pm

as anr mentioned, running ldd would give you a list of libraries expected by hazeron. Making sure you have all the packages that include those libraries should allow the game to run normally.
User avatar
Jey123456
 
Posts: 502
Joined: Sat Jun 25, 2011 6:26 pm

Re: 2016-08-03 Linux Package Requirements

Postby Haxus » Mon Oct 17, 2016 9:03 am

I am downloading the iso for Arch Linux now.

If it's not too much grief to get it installed, I'll see about building SoH on it.
User avatar
Haxus
Site Admin
 
Posts: 2731
Joined: Fri Jan 14, 2011 8:00 pm

Re: 2016-08-03 Linux Package Requirements

Postby Haxus » Tue Oct 18, 2016 5:56 pm

Arch Linux is too much work to install. Some sort of proper installer would help. Having to do everything yourself with command line is pretty arcane.

Sorry. I just don't have time to play with that kind of stuff any more. It used to be a lot of fun once.
User avatar
Haxus
Site Admin
 
Posts: 2731
Joined: Fri Jan 14, 2011 8:00 pm

Re: 2016-08-03 Linux Package Requirements

Postby Lysol » Tue Oct 18, 2016 7:40 pm

Was going to comment on the insanity of an Arch install and was going to tell you not to even try it. But your comment of utter defeat, Haxus, was worth it not saying anything. :twisted:
Lysol
 
Posts: 76
Joined: Sat Jan 15, 2011 4:20 pm

Re: 2016-08-03 Linux Package Requirements

Postby pizzasgood » Thu Oct 20, 2016 10:28 pm

I've been using Hazeron in Arch for a few years. Currently the Mint build of Hazeron seems to work best for me. These are the packages containing the libraries returned by ldd (ignoring the Programs/plugins/ directory):
Code: Select all
bzip2
dbus
expat
fontconfig
freetype2
gcc-libs
glib2
glibc
glu
graphite
harfbuzz
libcap
libgcrypt
libglvnd
libgpg-error
libice
libpng
libpng12
libsm
libsystemd
libutil-linux
libx11
libxau
libxcb
libxdmcp
libxext
libxi
lz4
nvidia-libgl
openal
pcre
sdl2
xcb-util
xcb-util-image
xcb-util-keysyms
xcb-util-renderutil
xcb-util-wm
xz
zlib

Note that you don't necessarily need all of those. I use the proprietary nvidia drivers, so some of those packages (particularly nvidia-libgl, and perhaps also libglnvd) won't be appropriate for everybody. My recommendation is to just run the game and then install whatever it complains about missing, perhaps using the above list if you need a hint for the package name.

Also, this build of Hazeron looks for libpcre16.so.3 specifically, which is not included in the pcre package, so I had to add a symlink pointing from libpcre16.so.3 to libpcre16.so to get it to work. I think that's the only thing I had to do by hand.

I'm not sure if you also need the dependencies for the files under Programs/plugins/. They seem a bit eclectic; I highly doubt, for example, that you must have libwacom to play the game. But in case some of these are necessary, here's a list of additional packages to satisfy most of those (ldd says I'm missing some of the libQt5 libs, and probably some of the things those depend on, but the game runs fine anyway):
Code: Select all
flac
json-c
libasyncns
libevdev
libffi
libgudev
libinput
libogg
libpulse
libsndfile
libvorbis
libwacom
libxkbcommon
libxrender
mesa
mtdev
qt5-base
qt5-declarative
qt5-location
qt5-sensors
tslib
wayland
Adapt or die.
User avatar
pizzasgood
 
Posts: 701
Joined: Sat Jul 21, 2012 11:50 am
Location: Space

Re: 2016-08-03 Linux Package Requirements

Postby Haxus » Thu Oct 27, 2016 4:00 pm

I must humbly eat my negative words about the new desktop in Fedora and Debian. After using it for a bit, it's actually very nice.
User avatar
Haxus
Site Admin
 
Posts: 2731
Joined: Fri Jan 14, 2011 8:00 pm

PreviousNext

Return to Updates

Who is online

Users browsing this forum: No registered users and 1 guest