Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Shader Linking Error
#1
When I get to the point, in the launcher, where I enter my credentials to log in, I get a string of windows popping up, telling me that various shaders failed to link. Fresh install of the game on Windows 10, 64bit.

Game is unplayable as, without these shaders, everything is just pure white.

Google search reveals that this problem had existed previously, but any solutions got deleted since they were on the Digiprose forums.


Attached Files Thumbnail(s)
   
Reply
#2
In the Settings menu before you login, go to the screne tab and try to enable/disable the "Shaders Support Non-Constant Sampler Array Indexes" option.


(01-28-2019, 04:36 PM)StreetCaptain Wrote: Google search reveals that this problem had existed previously, but any solutions got deleted since they were on the Digiprose forums.
I miss the old forum. T_T
Shores of Hazeron Wiki Moderator
hazeron.com/wiki/ User: Deantwo
Reply
#3
Still having the problem - enabling it did not fix it, and disabling it again also did not fix it.

Thank goodness Commander works, so I can at least check on my colonies.
Reply
#4
Update graphics drivers?

Only other thing I can think of is the duel GPU issue.
See: http://hazeron.com/wiki/index.php/Graphics_Issues
Shores of Hazeron Wiki Moderator
hazeron.com/wiki/ User: Deantwo
Reply
#5
It's a laptop, so there's only one GPU. Intel HD 520, drivers are up to date from the manufacturer.

I changed the settings to low memory (again, after another fresh install) and it seems to work now.
Reply
#6
The number of light sources can quickly overcome the available parameter space on some video drivers. That is why the default number is so low.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)