Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2020-05-22 Navigator Fail, Warp Signature, Module Repair and Upgrade
#1
Navigator Fail
If I issue a travel direct to solar system order, sometimes the ship just sits and wiggles.

Navigator now plots course correctly to all destination solar systems.

Travel direct to system coordinates menu option removed from an otherwise crowded menu. That item was there to work around this problem, as it let you order the ship to the precise galaxy coords of the desired solar system. It is no longer needed because the coordinate is embedded in the travel direct to system order.

Warp Signature
I detected a warp signature near my homeworld! I traveled there, only to find an abandoned decaying city that still had an airport.

Warp signatures are emitted by airports and base air terminals that belong to empires with warp technology. The assumption is that warp ships of their empire would be traveling between their own space ports.

I changed this slightly. Warp signatures are no longer emitted if the airport or air base has no workers.

Event Log Icons
A bug report included a screen shot of the event log in some in-game mail. The icons next to the events were incorrect.

Fixed offset error in a table of icon names used for events.

Autoclose Visor
It would be very handy if my helmet visor was automatically closed for me if my ship is destroyed.

Helmet visor now closes automatically if the ship you are aboard is destroyed.

You must already be wearing an EV helmet with an unbroken seal.

Smelting Metal from Bullion
The process of smelting metal from bullion does not consume any bullion.

Processes that smelt metal from bullion now consume the bullion. Bullion consumed in this way is reported in the bank transactions report as "Smelted Metal".

Previously the only processes that consumed money were patent developments. Money was consumed as RnD funds and paid to local citizens as salary, for a net 0 gain or loss to the local banking system. This logic did not apply when smelting because the funds are literally converted into something else, units of metal.

Manual System Upgrade
Still can't seem to manually upgrade my ship sadly >_

Fixed bugs and made improvements:
  • Removal of last system component now reports that it was the last component to be removed.
  • Fixed hit points overflow error that caused big strange numbers after removing a few modules.
  • Fixed a bug that broke the module type when upgrading a module by hand.
  • Damage report now shows No Module when all system modules are removed.
  • Damage report status icon is now grey when all system modules are removed.
  • First new module installed into a system with no modules changes the module type for the system. That is how you manually change a wormhole drive into a warp drive.
  • Fixed a bug that allowed the system module type to change by manually installing any new module, even if all previous modules were not removed first. You could remove one module and install a different one to change the type of any system, though the system was hopelessly broken after that.
  • If the damage report for your ship shows a requirement for more than one kind of module for an FTL drive, you may not be able to fix it. Tell me the name of the ship and I will fix it.
Station Offered Invalid Upgrades
I asked for upgrades to my warp drive module. The city responded with wormhole modules that were not valid for the system because I already had a different FTL drive with wormhole modules installed. A ship can have multiple FTL drives but no two of them can be the same drive technology.

Fixed suppression of invalid system modules in upgrade reply.

Station Upgrades Too Many Parts
I asked for upgrades to my warp drive module. The city responded with repair estimates but the numbers of parts in the estimates were their stock quantities, not the numbers that my ship needed.

Fixed repair estimate part quantities.

FWIW, the correct number of modules was consumed if an upgrade offer with incorrect quantities was accepted.
Reply
#2
(05-22-2020, 10:52 PM)Haxus Wrote: Manual System Upgrade
Still can't seem to manually upgrade my ship sadly >_

Fixed bugs and made improvements:
  • Removal of last system component now reports that it was the last component to be removed.
  • Fixed hit points overflow error that caused big strange numbers after removing a few modules.
  • Fixed a bug that broke the module type when upgrading a module by hand.
  • Damage report now shows No Module when all system modules are removed.
  • Damage report status icon is now grey when all system modules are removed.
  • First new module installed into a system with no modules changes the module type for the system. That is how you manually change a wormhole drive into a warp drive.
  • Fixed a bug that allowed the system module type to change by manually installing any new module, even if all previous modules were not removed first. You could remove one module and install a different one to change the type of any system, though the system was hopelessly broken after that.
  • If the damage report for your ship shows a requirement for more than one kind of module for an FTL drive, you may not be able to fix it. Tell me the name of the ship and I will fix it.

I was able to change the type of my FTL drive now. Cheers!
Of course as you mentioned, the ship says it needs way more modules then it should. Can you fix that? Or can Lightspeed? It is Deantwo's ship.

It does however still feel a little weird to change the type using a tool. When a subsystem is in the "no module" state, it would make more since that we would have to use an actual module on the subsystem in order to change it, or else we will not have control over which module from our inventory is used. After the type is changed a module would be used as normal.

Actually you could just make it so we could install/repair modules with a module from our hand, it would only install that one module so a tool is way faster, but it would make it more consistent and allow for quick installation of couple replacement modules even without a tool.

PS: I was able to use the power relay station to redirect power from my weapon bay subsystem to my FTL drive and get it online. It might be because the FTL drive's health is still rolled over, so if a subsystem's health can no longer rollover this isn't an issue worth fixing.
Shores of Hazeron Wiki Moderator
hazeron.com/wiki/ User: Deantwo
Reply
#3
(05-22-2020, 10:52 PM)Haxus Wrote: Navigator Fail
If I issue a travel direct to solar system order, sometimes the ship just sits and wiggles.

Navigator now plots course correctly to all destination solar systems.

Travel direct to system coordinates menu option removed from an otherwise crowded menu. That item was there to work around this problem, as it let you order the ship to the precise galaxy coords of the desired solar system. It is no longer needed because the coordinate is embedded in the travel direct to system order.


I got excited when I read this, because most of travel between my planets involve doing a series of 'direct to coordinate' orders until I'm close enough to issue a direct to system order.

I am sad to say the issue still exists.

Proof. Witness it in all its wiggling glory.

---
Some additional info about the very reproducible bug:

The wiggling issue only happens when a system is out of a certain range (like 2-3 sectors + I have noticed?)
Basically, if the system is not appearing in the list below, then it's too far and your ship is just going to wiggle:
[Image: 7Gd5kBu.png]
This has been the case for a long time now, and still is it would appear. Travel direct to coordinates was the only workaround I could find.


Hope that helps!
Reply
#4
There are a few different ways to issue the travel order. Which one did you use?
Reply
#5
(05-23-2020, 03:39 PM)Haxus Wrote: There are a few different ways to issue the travel order. Which one did you use?

I used the right click from the star map to issue the travel order, like below.

[Image: lvhzrJH.png]

I also tried right clicking from the right hand panel of the star map and the same thing happens.

The star map is the only way I know to reach distant systems, because they do not show in the list of 'named systems' from the add mission order menu if they are too far away.
Reply
#6
The navigator bug is fixed, pending next server restart.
Reply
#7
Yay! SO much better now. Thank you!

By the way, I hate to rain on the parade but I may have found a new bug with refitting ships--there is no option to 'accept offer' in the right click menu.
Module upgrades are working as normal however. It is just when you try to refit the ship (e.g. allocate more hold volume or whatnot).

See below: [Image: 09ZcG0T.png]
Reply
#8
I added the upgrade bug to my list.
Reply


Forum Jump:


Users browsing this thread: 3 Guest(s)