Thread Rating:
  • 1 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Manual Subsystem Upgrading not working
#1
Attempting to manually upgrade my spacecraft's FTL drive from a wormhole drive to a warp drive.

Once I had removed about 20-50 modules out of the total ~300 modules, the health bar was already empty. Attempting to insert a warp drive module gave the following message:
Code:
Deantwo: FTL Drive 38, Wormhole PNN FTL Drive Module repaired using Warp 1 FTL Drive Module Superb Q242 Made in Foxtail from my gear. The first new module changed the system type because all the old modules were removed or broken.
But the subsystem's type did not change.

I proceeded to try and remove all modules. I noticed that the quality of the subsystem had changed to that of the warp modules I had installed, which was weird but whatever.

I finally got all the modules uninstalled:
Code:
...
Deantwo: Superb Wormhole PNN FTL Drive Module removed from FTL Drive 38, Wormhole PNN FTL Drive Module.
Deantwo: Every Wormhole PNN FTL Drive Module has been removed from the subsystem.
I had dumped all the wormhole drive modules into the spacecraft's hold, and decided to just jettison them.

Now with only warp modules left, I took a warp drive module into my inventory and installed it into the service panel.
Code:
Deantwo: FTL Drive 38, Wormhole PNN FTL Drive Module repaired using Warp 1 FTL Drive Module Superb Q242 Made in Foxtail from my gear. The first new module changed the system type because all the old modules were removed or broken.
However the subsystem did still not change.

I attempted to remove the one module I had installed and noticed that I was getting wormhole drive modules, and a lot of them.
Code:
Deantwo: Superb Wormhole PNN FTL Drive Module removed from FTL Drive 38, Wormhole PNN FTL Drive Module.
...
I installed only one warp drive module but am able to uninstall another ~300 wormhole drive modules before I again get the message about having uninstalled all modules.

I have now done this multiple times and have gotten many many wormhole drive modules out and installed only a few warp drive modules that just seemed to vanish.

The Spacecraft Damage window is showing an ever increasing number of FTL modules that need replacing, and is seemingly tracking two separate FTL drive modules. When I install a warp drive module the two numbers merge and uninstalling modules starts a new counter from 0.

Spacecraft blueprint ID: 22112
Captain: Deantwo
Shores of Hazeron Wiki Moderator
hazeron.com/wiki/ User: Deantwo
Reply
#2
Same problem, but with sublight drive system. Everything exactly the same, except one thing: removing only four modules caused that system to be at 0 HP and removing rest of them raised HP counter to 4 billion while bar was completely empty.

UPD: here is a screenshot, just as a proof https://cdn.discordapp.com/attachments/2...nknown.png
I hope this link can be opened...
Reply
#3
(04-03-2020, 10:31 PM)Iajret Wrote: removing only four modules caused that system to be at 0 HP and removing rest of them raised HP counter to 4 billion while bar was completely empty.

[Image: unknown.png]

I haven't actually noticed what the health is reported as on my ship. I can check it in the morning.
But yes, seeing two numbers for modules like that is the exact same kinda thing I see for my FTL drive.

I wonder if that also explain the 4 billion HP pirate buildings.
Shores of Hazeron Wiki Moderator
hazeron.com/wiki/ User: Deantwo
Reply
#4
Code:
FTL Drive 38, Wormhole PNN FTL Drive Module
4.294.955.891/275hp 0%
275 modules missing/broken
893 ? (modules missing total?)
I don't know what the last number is still, but every time I attempt to install a warp module, the number of modules currently missing/broken is just added to it and I can repeat again.
Shores of Hazeron Wiki Moderator
hazeron.com/wiki/ User: Deantwo
Reply
#5
Fixed pending next server restart.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)